t f 5 s r
_

Lightroom 4.1 – Performance Problem gelöst!

Ich habe erst vor kurzem meine Adobe Lighroom Version von 3 auf 4 upgedatet. Zuvor hatte ich die Demo installiert und diese lief -im Gegensatz zu manch anderen Benutzern- genauso schnell wie Version No 3.

Aber schon kurz nach dem Update gab es die ersten Anzeichen, daß LR auch bei mir mächtig in die Knie geht, so wie bei vielen anderen Leuten auch. Das ging teilweise so weit, daß ich z.B mehrere Sekunden beim Umschalten der Module Bibliothek -> Entwickeln warten musste. Für jemanden mit einem derart kurzem Geduldsfaden wie mich absolut inakzeptabel! Auch diverse lokale Korrekturen mit dem Pinsel oder dem Verlaufswerkzeug verleihen dazu zwischenzeitlich sich eine Pizza bestellen zu wollen. Gedanken an die “Datasette” vom Commodore C64 kamen mir hoch. Da tippte man “LOAD “$”,8,1″ (oder so ähnlich) in die himmelblaue Basic-Maske und drückte die PLAY-Taste. Nach knapp 30 Minuten Hausaufgaben kam man wieder an den Fernseher(!) und biß sich vor Zorn fast die Hand ab, weil die Datenkassette einen “READ ERROR” produzierte und das tolle Spiel nicht geladen werden konnte… Tolle Zeit, die ich aber bitte nicht mehr so erleben möchte!

Aber genau das hat LR 4 mit mir gemacht; es versetzte mich in eine Zeit, wo ich auf den Rechner warten musste und nicht umgekehrt, wie es meiner Meinung nach sein sollte. Das ging nicht nur mir so: das Netz ist voll mit Performanceproblemen bezgl. LR. Auch das Update auf 4.1 hat bei mir keine (gefühlte) Verbesserung gebracht. Das Problem betrifft aber nicht jeden Benutzer. Bei einigen Leuten läuft die 4er Version gleich schnell wie die alte 3er – unabhängig von der Hardware-Power. Fakt ist, daß der neue 2012 Prozess (zu finden unter “Kamerakalibrierung” im Modul “Entwickeln”) meine Maschine tierisch ausbremst. Der alte Prozess 2010 oder gar 2003 laufen hingegen wie Schmidt´s Katze, aber wer macht denn bitteschön ein Update und läßt alle Verbesserungen links liegen bzw. deaktiviert diese? Nein, ich nicht…

Ich habe genügend Kenntnisse von der Materie, um zu wissen daß diverse allgemeine Lösungsansätze wie “Computer aufrüsten”, “Festplatte defragmentieren”, “LR Cache löschen und vergrößern” oder auch “Vorschaubilder löschen und neu rendern lassen”, nur Tropfen auf dem heißen Stein sind, die der Adobe Support mal so generell online veröffentlicht hat, um die User zu beschäftigen bzw. vom eigentlichen Problem abzulenken bis man konkrete Lösungsvorschläge bieten kann. bzw. ein Update herraus bringt, welche sämtliche Schwierigkeiten beseitigt. Zugegeben: der neue 2012er Prozess ist mit Sicherheit viel komplexer und braucht demnach auch deutlich mehr Unterstützung seitens der Hardware, aber mein selbst zusammengestellter Rechner ist gerade mal ein Jahr alt und alles andere als lahm. Dieser muss noch für mindestens zwei weitere Jahre ausreichend sein. Das kann es also nicht sein.

Heute jedoch habe ich ein Forum gefunden, wo ein User mit gleichem Problem seinen Chat mit der Adobe Hotline gepostet hat. Schnell ausprobiert und siehe da: LR läuft deutlich schneller im neuen Prozess! Ohne offiziell irgendwelche Zeiten verglichen zu haben, würde ich sagen minimum 50% schneller. Das ist doch schon mal was!

Und so funktionierts:
(frei übersetzt aus dem Englischen und teilweise ergänzt; gilt nur für Betriebssystem Win7)
ACHTUNG: macht mich ja nicht verantwortlich, wenn dabei etwas schief geht! Jeder löscht oder benennt Daten auf seinem Rechner um in eigener Verantwortung! 

  • LR schließen wenn geöffnet.
  • auf Start klicken.
  • in das Suchfeld direkt darüber %appdata% eingeben und mit Enter bestätigen.
  • Adobe-Ordner öffnen.
  • Ordner Lightroom in OldLightroom umbenennen.
  • wieder auf Start klicken.
  • im Suchfeld %temp% eingeben und mit Enter bestätigen.
  • in diesem temporärem Ordner alle Dateien/Ordner löschen.
  • LR öffnen.

Es kann sein, daß LR beim Starten jetzt fragt, ob ihr einen bestehenden Katalog oder einen neuen anfangen möchtet. Ich nehme mal an, daß ihr euren bestehenden Katalog weiter benutzen wollt. Also gebt ihr diesen an indem ihr die *.Ircat-Datei anklickt. Wenn ihr nicht wißt, wo eure Katalog-Datei sich befindet, dann schaut (bevor ihr das ganze Prozedere durchmacht!) in LR unter “Bearbeiten” -> Katalogeinstellungen und dem Reiter “Allgemein”. Dort ist an erster Stelle der Speicherort eures Kataloges angegeben.
Desweiteren sind jetzt wahrscheinlich all eure individuellen Presets verloren gegangen, sofern ihr überhaupt welche hattet. Aus diesem Grund geht es jetzt noch weiter:

  • LR wieder schliessen.
  • Start klicken.
  • wieder %appdata% in das Suchfeld eingeben.
  • Ordner Lightroom in 2OldLightroom umbenennen.
  • Ordner OldLightroom in Lightroom umbenennen.
  • im Ordner Lighroom den Ordner Preferences suchen und doppellklicken.
  • die Datei Lightroom 4 Preferences.agprefs in OldLightroom 4 Preferences.agprefs umbenennen.
  • LR starten und checken, ob die Presets wieder da sind (toi, toi, toi).

Ich hoffe, das hilft euch weiter etwas weiter mit eurem Performanceproblem. Wer auf das Prozedere keine Lust hat oder mir einfach nicht traut (mit Recht!), der wartet darauf daß Adobe RC 4.2 für Lightroom herrausbringt.

«
 
»

Share

5 comments to “Lightroom 4.1 – Performance Problem gelöst!”

  • Ruby, August 10, 2012 at 2:59 pm

    Hallo,
    auch bei mir ist Lr quälend langsam seit dem Upgrade auf Version 4.1. Deswegen wollte ich deinen Workaround ausprobieren.

    Frage: bei mir können nicht alle Dateien aus dem temporären ordner gelöscht werden. Ist das ein Problem?

    • Herr Mueller, August 10, 2012 at 3:40 pm

      Nein, das sollte kein Problem sein. Es geht ja auch nur um die LR-spezifischen Dateien und diese werden gelöscht wenn LR geschlossen ist.

  • Patrick, September 3, 2012 at 3:50 pm

    Danke, hat geklappt und scheint auch schneller.

  • Manfred, September 29, 2012 at 3:59 am

    ich traue mich nicht so richtig. Das scheint mir doch eine sehr weitreichende Änderung zu sein. Muss man nicht vorher irgendeine Sicherung oder so durchführen.

    Insgesamt verstehe ich auch nicht wirklich was das System da macht.

    • Herr Mueller, September 29, 2012 at 9:08 am

      Das wirkliche Wichtige, nämlich die Bilddaten sowie der LR-Katalog (Ircat-Datei), werden ja nicht angefasst. Es werden nur temporäre Teile der LR-Installation gelöscht, welche das Programm automatisch neu wieder herstellt – diesmal dann aber korrekt. Dennoch: ich kann natürlich keine Garantie geben, daß alles funktioniert!

Reply

What is 7 + 9 ?
Please leave these two fields as-is:
IMPORTANT! To be able to proceed, you need to solve the following simple math (so we know that you are a human) :-)